/var/tmp/node/wscript:319: error: Could not autodetect OpenSSL support.

  • Sun 05 June 2011

  • I'm attempting to setup NodeJS on my Xubuntu 11.04 I came up with this error when trying to build the package.

    /var/tmp/node/wscript:319: error: Could not autodetect OpenSSL support.
    

    Make sure OpenSSL development packages are installed. Use configure --without-ssl to disable this message. This fixed my dependency errors when configuring.

    sudo apt-get install libssl-dev
    

    Comments !

    social